No Bundle URL Present - iOS

Edit - Solved
Make sure your app is listed in “Settings > Privacy > Local Network”


SDK Version: 42
Platforms: iOS

I’m building with the bare workflow using expo run:ios -d to install the app on my device.

However, about half the time it won’t start with error: “No Bundle URL present”.

I start the package server with “react-native start”, and I ensure my phone is on the same Wifi network as my Macbook.

Last night when I went to bed, the app was connecting. This morning, it will not connect. I’ve tried:

Note that if I attempt to build with XCode, I get a separate error related to a Build Phase: “Bundle React Native Code and Images”. However, the expo run:ios -d command completes successfully.

If I use expo run:ios -d and choose a simulator instead of my physical device, then it works as expected. So, my best guess is that it’s a networking issue. But, I didn’t have this problem in the managed workflow prior to ejecting.

Any / all help is greatly appreciated.

Cheers,
Will

Yesterday I also tried upgrading to SDK 43, but I encountered other issues.

Today, I opened the app and it prompted for permission to connect to “Devices on Your Local Network”. I tapped to give permission, and it’s now connecting again =)

I don’t recall ever denying permission, but I suppose it’s possible I tapped the wrong button.

For others with this problem, make sure your app is listed in: Settings > Privacy > Local Network

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.