navigation missing

In the navigation docs, there’s nothing usable, no example whatsoever, and whatever I try from the external documentation, lead to:
Unable to resolve “@react-navigation/stack” from “App.js”
Which I found a lot of “solutions” for, but all don’t work. So I was hoping for someone to make an example for the latest Expo to use navigation, drawerNavigation

Unable to resolve “@react-navigation/stack” from “App.js”

i’m sorry i don’t understand where you are seeing this. are you running the code on a local project or in snack?

if you see this locally then the problem is that you did not follow the guide. you should go through the entire fundamentals section of the website or you are not going to understand how to use it. that’s what i wrote this section for. if you take a shortcut and avoid reading it you are only doing yourself a disservice.

as for snack, i just ran the first example on with the “Try this example on Snack” link and it worked as expected

Thanks for your patience. Today is a good day, and the “snack” works.
So I’ve build a more explainable example that perhaps is suitable for the expo documentation

I am new to this ecosystem. However, I found this same error while following the guide. I was able to resolve the error with

expo install @react-navigation/stack

It does appear that the current version of the guide is missing this installation step, which is confusing for those learning this particular set of tools for the first time.

Is expo install some sort of abstraction layer on top of underlying package managers (I think yarn rather than npm, in this case)? I tried to figure this out via $expo -h | grep install install|add [options] [packages...] which says that the command Installs a unimodule or other package to a project

it’s in the first page after “Getting Started” in “Fundamentals” - the page called “Hello React Navigation” -

it’s also listed in the createStackNavigator docs page:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.