MapView crash on Standalone android after uploading to Google Play

Please provide the following:

  1. SDK Version:40.0.0
  2. Platforms(Android/iOS/web/all):Android

I use react-native-maps in my project. My project was developed using Expo SDK 37 and it was working fine. I tried recently to run the “expo-upgrade” command to upgrade to Expo SDK 40. I fixed some errors that I found in development mode and then I executed the command: “expo build: android”, selected to generate Bundle instead of APK, and then I got my bundle file. I uploaded that bundle file to Google Play Console in Internal Test release mode. When I downloaded the Internal Test version from Google Play and went to the Map page, the app crashes and reload immediately and I’m being able to see the map Screen.
Video showing the problem: Issue React native maps - YouTube
Ps: It was working fine with Expo SDK 37 before upgrading to Expo SDK 40
My app.json:

“android”: {
“package”: “”,
“versionCode”: 123,
“packagerOpts”: {
“config”: “metro.config.js”,
“sourceExts”: [“js”, “jsx”, “svg”]

Hey @giganetdev, I would recommend creating an apk and installing it locally on a device or emulator and then investigate the device logs with adb logcat. See these docs: Debugging - Expo Documentation


Thanks for your support! I tried to eject Expo and use Bare Workflow. It worked flawlessly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.