Issue with standalone IOS build on app submission IPV6 network iPad

Bellow is the message from Apple. I have not yet tested it on an iPad myself on an IPV6 network since I don’t have one.

I am not exactly sure what is happening.

Guideline 2.1 - Performance - App Completeness

We discovered one or more bugs in your app when reviewed on iPad running iOS 10.3.3 on Wi-Fi connected to an IPv6 network.

Specifically, the app does not load any content.

The steps to reproduce are:

  1. Launch the app

Please see attached screenshots for details.

Next Steps

To resolve this issue, please run your app on a device to identify any issues, then revise and resubmit your app for review.

If we misunderstood the intended behavior of your app, please reply to this message in Resolution Center to provide information on how these features were intended to work.

For new apps, uninstall all previous versions of your app from a device, then install and follow the steps to reproduce the issue. For updates, install the new version as an update to the previous version, then follow the steps to reproduce the issue.


For information about testing your app and preparing it for review, please see Technical Note TN2431: App Testing Guide.

For a networking overview, please review About Networking. For a more specific overview of App Review’s IPv6 requirements, please review the IPv6 and App Review discussion on the Apple Developer Forum.

1 Like

Some resources for IPV6 App Testing:

This has been fixed by rebuild

Im having the exact same issue, they test on an iPad, say it could be related to iPv6 but i’ve submitted it numerous times now to no avail

Yeah I rebuilt it and it worked.

1 Like

I’m losing my mind. This is the first time i got a rejection from App Store, and is using React Native + Expo. Why is this happening? i used the exp build:ios command, rebuild doesn’t change a thing, since i have send it 3 times, same error everytime, and the error is the same, how can you fix this error? i’m losing so much time with this problem and the client is already furious.

@solitaryo did you get the same msg from
apple as the first post in this thread?

Exactly the same msg from apple. rejected for FORTH time. I enabled ipV6 on my API server, and still, app rejected.

Have you tested your standalone app via TestFlight? The problem might be completely unrelated to IPv6. For example, perhaps the Apple reviewer just loads your app on an IPv6 network intending to test whether it works with IPv6, but your app just fails to load for some other reason.

I have tested the app via Test Flight with 6 testers and 3 different iPhones, works flawless, but they keep rejecting the app.

when I tested it via IPv6 it worked fine for me even the same version they rejected.

I am not sure if they do some more crazy tests. What I did also was disable remote fetching for the bundle.