iOS Simulator preventAutoHide()

Screenshot 2020-08-20 at 17.10.10

Second day trying to solve this and no luck.
I’ve seen many other threads relating to this splash screen issue but i noticed something strange:


expo client:install:ios

in the terminal, then clicking on Expo in the simulator – the above screenshot message is displayed – i havent done expo start

seems this isnt an issue with my app but maybe with expo app itself??

Have tried a variety of solutions from threads from SO etc but no consistent solution.

It seems expo is trying to open before the js bundle is built perhaps? Occasionally it works! trying to narrow down scenario when it works.

SDK 36.0.0


We’re getting the exact same on v38

1 Like

Did you get this issue resolved?

Hi Jacob – not resolved unforunately.

Have you had any luck?

Im looking at uploading a new binary to Play Store and looks like a need to upgrade to latest Expo SDK – once ive got through this likely painful breaking changes process ill see if there are still issues with the Expo app issue mentioned in this thread.

Hey, sorry for late reply… No luck yet.
Tried to run completely new projects again - even using an older SDK - and still I face the same issue.
I also made sure my OS and Xcode were up to date and cleared all contents and settings from my simulator.

I noticed a text when running my project that expo-splash-screen was not compatible with the latest Expo SDK version. I updated the packade accordingly, but that did not help at all.

Have this issue been addressed at all by Expo Staff yet? - cause it’s really becoming an issue in my everyday work.

Sorry to for dragging your attention to this issue like this @adamjnav, @notbrent and @wkozyra. But I just want to make sure you’ve at least seen it. Maybe you already know the solution? :slight_smile:

Related issue:

hi Jacob.

I was trying to solve a different issue and upgraded SDKs from 36 → 38 … then used the CLI to upgrade the expo apps on the simulator accordingly ----- i had a raft of breaking changes, so then downgraded back to 36 (will increment up gradually) … BUT … the ios Expo app is now working … and im able to test my app!

are you able to do a similar manoeuver ?



Thanks for your reply and suggestion :slightly_smiling_face: I tried it out, but did not get it to work.
Any chance you could pass an each-step-list of all actions you took?

Thanks in advance!