Invalid Apple credentials for build:ios

I tried both

I will provide all the credentials and files needed, Expo does limited validation
And
Expo handles all credentials, you can still provide overrides

I even disabled the 2 factor authentication, earlier this used to work. Is expo using some website /app of iosconnect where my account is disabled and I can figure out what’s wrong.

Btw I am using windows.

I would enable 2FA back on. And show your error message if you have one.

Do try to be on latest version of exp, also can you do in powershell.

bash.exe -c 'uname -a'

(Also please make your own forum thread when you have an issue)

@edgar Sorry about using the same thread.

bash.exe -c ‘uname -a’

Below is output
MINGW64_NT-10.0 XBSDZ 2.5.0(0.295/5/3) 2016-03-31 18:47 x86_64 Msys

It used to work in the earlier versions

This is the wrong bash.exe.

You need to be using the one provided by WSL, that is officially provided by Windows.

When I use powershell, the command says.

Linux XBSDZ 4.4.0-43-Microsoft #1-Microsoft Wed Dec 31 14:42:53 PST 2014 x86_64 x86_64 x86_64 GNU/Linux

When I use wsl it says

Operation not supported .

Do you have a bash at: C:\\Windows\\system32\\bash.exe ?
some instructions:

Download from the Windows app
store a distribution of Linux, then in an admin powershell, please run:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

and run the new Linux installation at least once

I do have bash, does this mean. I have to install exp for the linux subsystem

No, it means that you need to have a working bash at: C:\\Windows\\system32\\bash.exe.

so when you do:

 C:\\Windows\\system32\\bash.exe -c 'uname -a`

everything should work.

I installed exp on linux subsystem and tried to build it worked.
I ran below command

C:\Windows\system32\bash.exe -c 'uname -a`
and got
Linux XBSDZ 4.4.0-43-Microsoft #1-Microsoft Wed Dec 31 14:42:53 PST 2014 x86_64 x86_64 x86_64 GNU/Linux

But it doesn’t work via gitbash like it used to, but it worked like a charm on sys bash.
So sorry, I am asking too many questions :frowning:

Also why when I build even when I had that issues, my production release would be replaced with this one.

Okay so to be clear, exp build:ios works for you now?

(Ask as many questions as you want :slight_smile: )

Yes but after I installed exp on my substem linux. Not via windows.

What version of exp are you on and what is the error when you do it on windows?

Exp version 49.2.2
And now on windows it says

Using existing credentials for this build
Well the build is working on windows too
Not sure what happened but you are my hero @edgar

Hi,

I’m having the same issue, “Invalid credentials”, although I published several times before without any issue.
Tried many times - pretty sure my credentials are ok
I’m on a Macbook, exp Version 49.2.2

This happened when I tried to publish a new app, under a new iTunes company/team. Could it be related ? That before my Apple account was part of only one team, and now part of two ?

@herdani

Hi there,
Whatever your AppleID+password are, they are sent as it is to log into Apple, exp doesn’t do any processing. Do you have a whitespace in your password?

(also, usually its better to make your own forum post)

@edgar

Hi, thanks for your reply, and I do indeed have whitespaces in my password. I’ll remove them and try again. I’m a bit concerned also about the provisioning though: how will expo know on which iTunes team it has to work ?

PS / Should I start a new thread or can we continue here ?

Thanks!

Can continue here:

exp will ask you for which teamID to pick if you have more than 1 available teamID

(The whitespace limitation is because of another upstream library used)

Hi @edgar,

Everything works as expected now, thank you for your availability!

I had the same problem. My password contained a space. I changed it and afterwards it worked fine.

Could it be expo clears spaces in the passed password in order to avoid trailing spaces, but in turn also removed the spaces in the password itself even if they are intended?

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.