"Input is required, but in non-interactive mode" Where is interactive mode flag?

On a windows 10 environment, running the command in git bash, I’m trying to run “exp build:ios” and getting some issues:

[18:24:45] Checking if current build exists...

[18:24:45] No currently active or previous builds for this project.
[18:24:46] Error while gathering & validating credentials
[18:24:46] Input is required, but exp is in non-interactive mode.
Required input:
> How would you like to upload your credentials?

It’s not letting me give input when running exp command with no flags. I want to know how to give it that input. exp --help did not help.

How do I run exp in interactive mode?

Default mode is interactive.

We’re checking if exp is run in TTY, and if not then exp also works as non-interactive.

Maybe try different cmd for Windows?


Indeed, using powershell worked.

1 Like

Glad you got things working!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.