How to build monorepo on windows 10

Hi, I forked and cloned the expo sdk. When I tried to build with ‘npm run setup:native’ it threw an error running a bash script “./scripts/…/…sh” ( I don’t have the exact error I’m on mobile)

How do I build on windows. Would cygwin or wsl work?



As long as Linux works, WSL should too. I would be much less certain about Cygwin.
I’ve not tried building it before though.

I’m still having problems with running “npm run setup:native”
I’m using wsl derbian

below is my error msg

DESKTOP-CPVILRR:/mnt/c/users/nickg/desktop/expo_opensource/expo$ npm run setup:native

@expo/expo@1.4.0 setup:native /mnt/c/users/nickg/desktop/expo_opensource/expo
./scripts/ && ./scripts/

Entering ‘docs/react-native-website’
Updated 0 paths from the index
Entering ‘packages/react-native-unimodules’
Updated 0 paths from the index
Entering ‘react-native-lab/react-native’
Updated 0 paths from the index
00h00m00s 0/0: : ERROR: There are no scenarios; must have at least one.
npm ERR! errno 1
npm ERR! @expo/expo@1.4.0 setup:native: ./scripts/ && ./scripts/
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @expo/expo@1.4.0 setup:native script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm WARN Local package.json exists, but node_modules missing, did you mean to install?

npm ERR! A complete log of this run can be found in:
npm ERR! /home/deadset17/.npm/_logs/2020-02-12T18_00_58_881Z-debug.log

thanks in advance

This seems to be this issue …

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.