expo init on Windows Fails Downloading Vector Icon Dependency

I am running expo-cli on Windows to create a brand new React Native project but it is failing because of a missing dependency. The commands I entered are below.

npm install -g expo-cli
expo init my-app

The error I receive is below.

npm ERR! path git
npm ERR! code ENOENT
npm ERR! errno ENOENT
npm ERR! syscall spawn git
npm ERR! enoent Error while executing:
npm ERR! enoent undefined ls-remote -h -t ssh://git@github.com/expo/vector-icons.git
npm ERR! enoent
npm ERR! enoent
npm ERR! enoent spawn git ENOENT
npm ERR! enoent This is related to npm not being able to find a file.

I am not sure if there is a bug in expo init or if something is messed up in my environment. I just got started and tried following the Getting Started directions, so it seems odd that my environment would already be messed up.

Environment information below.

Windows 10
Node 10.15.0
NPM 6.6.0
expo-cli 2.6.14

Hey @jcraft,

Can you ensure you have git installed? https://git-scm.com/book/en/v2/Getting-Started-Installing-Git



@adamjnav, yes, I just realized that is probably the problem. I have Git installed but I don’t believe it’s in my PATH and that’s why Node can’t find it.

I will update my PATH and see if that solves the problem.

@adamjnav, that was it. I added Git to my PATH environment variable and expo init works now.

Thanks for your help.

1 Like

Awesome. Glad to hear it!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.