Google Sign-In Installation

Hi, i’m following the guide at: but when i run openssl rand -base64 32 | openssl sha1 -c it says: openssl is not recognized as an internal or external command. How can i fix this?

Are you using a Mac or running Linux or what platform are you on?

Hi ccheever, i’m on Windows

openssl is a program that’s on most Unix-like systems. I wouldn’t be surprised that it’s missing on Windows. I don’t think it’s worth installing it on Windows for this one-time command – it just generates a random string of the form: 35:42:fd:94:ab:71:61:5e:3c:9f:ec:37:cc:b8:8e:75:3b:4d:04:8f. If you generate that string some other way (pick random numbers and characters yourself – though humans aren’t always great sources of strong randomness – or write a small program to do it) that would be fine.

Were you ever able to solve this problem? I tried ‘npm install openssl’ and then posted the command from the Expo site, but I’m still unable to generate a key. I still get the same error you got.