"Failed building JavaScript bundle."

Is it possible to get more information on why it’s failing? What are the common reasons for failure?

expo start gives a QR code and then this:

Logs for your project will appear below. Press Ctrl+C to exit.
[02:55:55] Opening iOS simulator
[02:55:57] Opening exp://localhost:19000 in iOS simulator

Then the simulator starts up and shows this screen:

(the IP is correct)

Then the terminal starts the “Building JavaScript bundle progress bar”, and ends with:

[02:56:34] undefined
[02:56:34] Failed building JavaScript bundle.
[02:56:35] undefined
[02:56:35] Failed building JavaScript bundle.
Building JavaScript bundle [======================================================= ] 99%

And it hangs at 99%.


I think we all need some more information.

  1. Are you on your own Wifi network?
  2. Is the Wifi network open (can devices reach eachother)?

Have you tried using another network. For example: a Hotspot from another mobile phone?

1 yes 2 yes, it has worked previously with same set up

i have the same problem
[Failed building JavaScript bundle]
I have the same netowork its open and i tried to conect them with personal hospot from my phone but the result doesn’t change

One thing I can think of is to try to delete the .expo folder and reinstalling expo-cli and seeing what happens?

The problem was I was using npm link. Fixed by switching to wml:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.