Expo start LAN IP address defaults to instead of my local IP address after Windows and Expo-CLI update. Cannot change it regardless of what I've tried.

Relevant expo diagnostics:

  • Expo CLI 3.21.13 environment info:
    OS: Windows 10 10.0.18363

    expo: ^38.0.0 => 38.0.8

I am trying to run expo on my windows PC, but I can’t seem to get it to run on LAN.


I am on my local Wi-Fi.

This is what I have tried:

  1. Set the environment variable in Powershell with $env:REACT_NATIVE_PACKAGER_HOSTNAME = "", then run expo start.
  2. Clear .expo file, then run expo start.
  3. Run expo start -c to clear the cache.
  4. Setting my wi-fi network to “private” instead of “public”
  5. Disabling the firewall.

This all started happening after a recent Windows update, as well as after I updated to the latest expo-CLI. Both updates happened more or less at the same time, so it is difficult to pinpoint what was the original cause.

Creating a tunnel works fine, but it is slow to update when I make changes, as my local wifi is not very fast. I can also run an Android emulator.4, but I want to test some things on a physical device without having to use the “tunnel” option.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.