Expo SDK 15 to 18 breaks XDE simulator

Error received when trying to build project on Expo XDE:
error: unknown option ‘–customLogReporterPath’

Followed instructions here: https://blog.expo.io/expo-sdk-v18-0-0-is-now-available-38e62305283 under the section ‘Upgrading your app’

However instructions are for upgrading from 17 to 18, not 15 to 18. Maybe i’ve missed out some crucial instructions in between. This project was originally created as a new project on Expo, not through other methods like create-react-native-app / xcode etc.

Here’s the current dependencies of the project

react-native: "https://github.com/exponent/react-native/archive/sdk-15.0.0.tar.gz"
react: "~15.4.1"
expo: “^18.0.4”

sdkVersion: “15.0.0”

Hi! Most of the instructions for going from 17 -> 18 should be the same. It looks like didn’t update the react-native, react, or sdkVersion fields in those files, which would definitely cause this problem. Once you’ve updated those and followed the rest of the instructions, let us know if you have any other issues!

hey there!

from 15 - 16, 16 - 17, 17 - 18 should definitely not cause this problem too right? yet to test but will do so later and see where things go wrong. i only tested 15 - 18 and got this error. could be something else that was breaking the code in node_modules but i am not sure either, when i reverted the project back to 15 and all the previous settings it worked fine again. just in case this might be useful:

“dependencies”: {
"@expo/react-native-action-sheet": “^0.3.1”,
“axios”: “0.15.3”,
“expo”: “^18.0.4”,
“firebase”: “^4.1.1”,
“latlng-to-zip”: “0.0.1”,
“lodash”: “4.17.4”,
“qs”: “6.4.0”,
“react”: “~15.4.1”,
“react-native”: “https://github.com/exponent/react-native/archive/sdk-15.0.0.tar.gz”,
“react-native-action-button”: “^2.6.9”,
“react-native-aws3”: “0.0.8”,
“react-native-clean-form”: “^0.4.1”,
“react-native-communications”: “^2.2.1”,
“react-native-easy-grid”: “^0.1.13”,
“react-native-elements”: “0.10.2”,
“react-native-image-picker”: “^0.26.3”,
“react-native-searchbar”: “^1.10.0”,
“react-native-star-rating”: “^1.0.7”,
“react-native-vector-icons”: “^4.2.0”,
“react-navigation”: “1.0.0-beta.7”,
“react-redux”: “5.0.3”,
“redux”: “3.6.0”,
“redux-form”: “^6.8.0”,
“redux-persist”: “4.6.0”,
“redux-thunk”: “^2.2.0”

Not sure what the error implies though… :thinking:

It looks like the react-native and react package versions don’t match the expo package version (from the upgrade guides) – I think that would definitely cause a problem. Also, if your exp.json/app.json has an sdkVersion of 15.0.0 but expo is 18.0.x, then you’ll probably have issues there too.

You may want to look at the SDK 18’s new project template package.json and app.json as a reference.

Sorry about the versioning issues, we know that this process should be easier and more automated.

What I had meant was that I had already tried updating directly from sdk 15 to 18 with the following:
“react”: “16.0.0-alpha.12”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-18.0.1.tar.gz”,

but it ended up giving the error of error: unknown option '–customLogReporterPath’
I did not update any other dependencies though.
I reverted back from SDK 18 to 15 and changed to what I had mentioned in my first post and I do not get that error anymore.

– EDIT –
just tried updating from 15 to 16 as per instructions https://blog.expo.io/expo-sdk-v16-0-0-is-now-available-2151d555a580

Scanning 628 folders for symlinks in /Users/mins/Desktop/trnr/Expo/trnr2/node_modules (5ms)
error: unknown option `–customLogReporterPath’

using rm -rf node_modules && npm install, exiting expo and restarting the project got the simulator to work. BUT i encountered this problem, which I had previously encountered when trying to upgrade from 15 to 18 (before getting the first error I stated here). tried rm -rf … again but nope still getting the same problem. on second thought i might get a better chance at posting on react-navigation’s issue instead, could be react/react-native causing this instead of expo. - i just checked again now and indeed its a problem with the individual libraries (react-navigation and react-native-easy-grid) not working well with the new versions of react/react-native, not expo.

"Unable to resolve module ‘react/lib/ReactComponentWithPureRenderMixin’ from ‘Users/mins/Desktop/trnr/Expo/trnr2/node_modules/react-navigation/src/views/Header.js’: Module does not exist in the module map or in these directories: /Users/mins/Desktop/trnr/Expo/trnr2/node_modules/react/lib, /Users/mins/Desktop/trnr/node_modules/react/lib

but it was good to verify that 15 - 18 should not cause any breaking changes. thanks so much! :slight_smile: