Expo push notifications not working after build

SDK Version: 40 Platform: Android

The push notification is only working in development mode in development device it’s not working in development mode in other device… (fcm setted) after I build using bundleRelease (eject) and published to playstore. it’s not working could I set as production in google console or expo console ? where ? I’m testing with insomnia (exp.host/–/api/v2/push/send) and it’s ok in development, but not in other devices and production , why working in one device and not in others device in test ? I see the exponent push generated after install as well

I recently tried:

// Notifications.setNotificationHandler(null); //tried as well

handleNotification: async () => {
return {
shouldShowAlert: true,
shouldPlaySound: true,
shouldSetBadge: false,

the problem is caused because I’m using gradlew assembleRelease to build ? Need I build with eas build platform android ???

I’m currently using exeperienceId: @username/slug and not ApplicationId to register the push tokens

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.