Expo Publish is not considering updated assets - App Icon


I am having this issue of updating my app icon.
But somehow expo server is seeing that asset is not changed and it’s not considering an updated asset.

How do I force expo to get this new asset while publishing my app?

I have removed all the cache and metro files and reinstalled node_modules. Nothing is worked.

Even deleted my project and recreated that project again and still the same issue.

Any help is appreciated.

expo publish with new release channel also giving this same result

[00:04:30] Building iOS bundle

[00:05:19] Building Android bundle

[00:06:04] Analyzing assets

[00:06:07] Uploading assets

[00:06:07] No assets to upload, skipped.

[00:06:07] Uploading JavaScript bundles

[00:06:13] Published

[00:06:13] Your URL is


If your app is a standalone app (i.e. you are not running it inside Expo client), you’ll need to run expo build:ios or expo build:android and release new apk/ipa to get the app icon to update.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.