Expo notifications not working on device for test after eject [iOS]

Just ejected my expo managed app from Expo SDK 40 to the bare workflow but notifications are received only when using Expo Go client. Nothing when running the app with yarn ios. Is that normal and is it expected to work when submitting to the app store?

I have submitted my credentials to expo server and when using the expo api sending a test notification, I get a status OK answer. But nothing happens on the phone.

However, when launching the app with expo start, I can receive the notification.
Do I miss anything?

1 Like

So I built the project and submitted to the app store with EAS to test it in TestFlight. And I confirm the notification doesn’t work with my app. However, it does work when I launch the app in Expo go on my device locally. When using my expo token with the curl command from the doc, I still get a OK status using the token I get back from the app which means that my credentials seem to be uploaded to Expo servers properly. I did inserted my experienceId (@username/app_slug) when calling getExpoPushTokenAsync. Anything I’m missing?

I need support in this either, I push my FCM key to expo servers, and it’s work in android I don’t know if I had to do anything to ios before publishing in testflight to be worked?

Ended up reimplementing my notification system with firebase cloud messaging instead of expo. Expo got many convenience but needed this to work ASAP.

1 Like