Expo Push Notifications not working when using Testflight and Expo Client


I’ve recently encountered a problem. I’ve integrated push notifications (from Expo) in my app and it works great on all devices. It used to work on my iPhone XS (iOS 12.0.1) through the Expo Client, but after I also installed the standalone app through Testflight, it doesn’t seem to work anymore (cannot remember if I ever got any push notifications from the standalone app or not). I’ve tried to send push notifications directly to my phone by using the push notification tool and it seems to work on the site (I’m not getting any error messages, just a green button), but I’m not recieving anything in my phone. I’ve also tried to uninstall/reinstall both the standalone app and the Expo Client (having one installed and uninstall the other etc), but I’m still not recieving any notifications. Permissions looks fine as well.

Could it be that my phone is confused since I’ve used both the Expo client and the standalone app? It works on other devices through Testflight, so I’m not sure what’s the problem…

Is this a known issue?


Nevermind, solved this. I mixed up the different tokens.

Hey @niclasericsson,

Glad you got to the bottom of it.



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.