Expo-image Pod install error.

I updated my app by using the new ‘expo-image’ package. When I ran expo build, I got this error:

Error: Build failed: Compatible versions of some pods could not be resolved.
You are seeing this error because either:

  • Versions in the cached Podfile.lock do not match required values in Podspecs of some installed libraries. To fix this, you can re-run build command with “–clear-cache” option, or select “Clear cache and retry build” on the build page.
  • Some of the pods used in your project depend on different versions of the same pod. See logs for more information.

I cleared my cache on new build to try again. Same issue. I then pulled up my project right before I used ‘expo-image’, and eas build ran just fine. Is anyone else having issues with the new expo-image package?

I’m not sure if I scrap expo-image or if there is something I am missing. Also it worked great on the simulator and on my mobile expo app.

Hi @tay8rocker

Do you have an ios directory in your app?

If so, do you intend to be on the Bare workflow?

If you have an ios directory, but you did not intend to be on the Bare workflow, you should delete the ios directory. (Same for android).

Also, run npx expo-doctor to check for possible version mismatches with your dependencies.

I currently dont have an ios or android folder. I ran npx expo-doctor and everything looked good.

Here are some of my dependencies. I have other some image packages. Is it possible that packages conflict each other even though I am calling the ‘expo-image’ packages when I am using it? Or am I using the ‘expo-image’ package prematurely?

Please post the dependencies and devDependencies as text. You can use the </> button to avoid the forum software trying to interpret the ones that start with an @ sign.

I’m not sure, but maybe.

You might also try looking for more details on the “Some of the pods used in your project depend on different versions of the same pod” issue. Maybe check the Xcode logs.