Expo, exp detach

I’m trying to detach an expo but get this error

andreass-mbp:repos andreaslillvik$ expo init pure3
? Choose a template: expo-template-blank
andreass-mbp:repos andreaslillvik$ cd pure3
andreass-mbp:pure3 andreaslillvik$ exp detach
We've built a brand new CLI for Expo!
Expo CLI is a drop in replacement for exp.
Install: npm install -g expo-cli
Use: expo --help
Read more: https://blog.expo.io/expo-cli-2-0-released-a7a9c250e99c
[20:49:10] Making sure project is set up correctly...
[20:49:11] Your project looks good!
Moving Android project files...
Downloading Android code...
{ buildPhase: 'copying initial shell app files' } 'Warning: Could not copy run.sh to shell app directory.'
{ buildPhase: 'copying initial shell app files' } 'Warning: Could not copy maven to shell app directory.'
Updating Android app...
{ buildPhase: 'running shell app modifications' } 'Warning: No config file specified.'
[20:49:25] ENOENT: no such file or directory, open '/Users/andreaslillvik/repos/pure3/android/run.sh'
[20:49:25] Set EXPO_DEBUG=true in your env to view the stack trace.
1 Like

What sdk version are you using? I think around sdk 28 they released expo cli and you should be using expo-cli rather than the old exp command to run these types of tasks.

npm i -g expo-cli

Then you run

expo eject

I’ve tried expo eject but it gets the warning Unable to install expokit@32.0.5. And there is also no run.sh in the android folder.

Installing 'expokit' package...
Unable to install expokit@32.0.5.
Please install manually to complete detaching.
Finished detaching your project! Look in the `android` and `ios` directories for the respective native projects. Follow the ExpoKit guide at https://docs.expo.io/versions/latest/guides/expokit.html to get your project running.

Did you install expo globally beforehand? npm i -g expo

This is not the same as expokit.

I have the same problem, if you find a solution, please publish it!

I’ve installed expo-cli and exp globally before. Now I’ve also installed expo globally and also updated to latest expo-cli.
Expokit is now installed without any problems. But there is still no run.sh in the android folder as it should be according to https://docs.expo.io/versions/latest/expokit/expokit/

I’ve still not found a solution. Have you?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.