Expo, exp detach then fail url qr

Hi. I did a detach of an app to learn how is the use of Expokit and after it finished, I saw that everything was fine. Then create another project from scratch using $ exp init, everything goes fine but at the moment of generating the url that generates the code qr it returns a value that I never saw and the QR code does not work from the XDE and from the console using $ exp start no generates the qr code directly.

The address that generates me is the following, working in the local network:


If from the Expo client on the cell phone entry: exp:// it works fine, but I do not understand why it appears:


Can you help me solve it?
Thank you.

PS: Before doing the detach everything worked fine without problems. Now uninstall the exp client, delete the ~/.expo folder and reinstall everything again but keep doing the same.

Hey there. Your detached ExpoKit project is not designed to load in Expo Client any more, since it supports custom native code. Since it opens in a different app, it uses a custom URL scheme like exp<uuid>.

To run an ExpoKit project, use Xcode or Android Studio instead of Expo Client. See this article for more info.

Hi ben, if I read that in the instructions, even once the detach is done you can not go back. But I refer to the other projects that I have in Expo without doing detach the same thing happens to me, when I return a long url that is not what I usually see when I work on my Expo projects.

Hi Ben, I must have another problem because I opened another old project and generates the url and the QR code well. Thanks for your help.

1 Like

I already found my mistake! When I did the detach and saw that everything worked fine, knowing that I could not go back to the project, I copied my files and folders (except for the ios and android folders) and when creating the new project I wrote everything in the new project, among them the app.json file. After talking to you (I did not realize to enter before, sorry), I saw that in the end was the key “isDetached”: “true” and well … I removed that and everything worked again!
I leave this here in case it happens to someone else.
Greetings and happy holidays!


1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.