Expo Cant Run Release Build


First… Sorry for my bad english…

I developed a React Native App with Expo that I ejected, but when i’m trying to build a standalone app and run on device, but the app doesn’t work. The Expo app shows me “Uncaught Error: Could not load app”. I already tried build a signed APK from Android Studio and doesn’t work, also tried build using this steps:

react-native bundle --platform android --dev false --entry-file App.js --bundle-output android/app/src/main/assets/index.android.bundle --assets-dest android/app/src/main/res/

cd android && ./gradlew assembleRelease

adb install -r ./app/build/outputs/apk/prodKernel/release/app-prodKernel-release.apk

But I still get the same error.

Also tried the steps described in Docs: https://facebook.github.io/react-native/docs/signed-apk-android

But when I get the APK, move to my device and installed, when i run I still get the same error.

I’m already published my app with expo publish command.

Detail: When I’m running the Expo Server and start the Dev App, works fine, the problem is in Production Release.

How can I build my APK to distribute to my final users?

Found any solution @igor.pires ? I stumble upon the exact same problem