Create release apk after eject to ExpoKit not working

Hello,
I worked with the regular Expo for the last months but now I need to eject.
So I run expo eject and choose eject to ExpoKit.

I build and run the debug application and it worked fine, now I want to create a signed release apk but after installing it I got a failed message when I open the application.

These are the steps I made for running in RELEASE mode:

  1. expo publish
  2. open AndroidStudio
  3. Generate signed APK and choose my key file and put the alias and the passwords I got from expo when I built with them
  4. I tried to installed the apk that was generated but got: "Something went wrong, Cloud not load app"

I also tried to run the ./gradlew assembleRelease but I got the same message.

What am I missing ?

did you publish your JS bundle before building using expo publish? I’m guessing this is an Expo “blue screen” error. It sounds like it can’t find the JS bundle (which is added to your Android project resources for local loading as well as to the cloud when you publish).

Yes it is the first command I run before building the apk.

And yes you are right it is the expo blue screen.

Did you change slug or release channels or anything like that? Definitely sounds like the Android app isn’t pointing to the JS. Does everything match between what you’re publishing and what’s in AppConstants.java? If there’s an option to view error details on that blue screen, check it out, there might be a hint in there (like a URL it’s looking at).

In addition to Keith’s suggestions, I’d connect your device and enable USB debugging and run adb logcat in Android Studio. Device logs will provide much more insightful crash information.

My issue solved!
@llamaluvr thank you for referring me to check the release channels and the AppConstans.java
what happens to me is that my colleague did the eject with a different expo account so after replacing all the publish urls to point my account instead of his account everything worked!

Thanks again

1 Like