expo bare workflow development build not opening

This is my Package.json
“name”: “testapp”,
“version”: “1.0.0”,
“main”: “index.js”,
“scripts”: {
“start”: “expo start --dev-client”,
“android”: “expo run:android”,
“ios”: “expo run:ios”,
“web”: “expo start --web”
“dependencies”: {
@react-navigation/material-top-tabs”: “^6.6.3”,
@react-navigation/native”: “^6.1.7”,
@react-navigation/native-stack”: “^6.9.13”,
“expo”: “~48.0.18”,
“expo-av”: “~13.2.1”,
“expo-dev-client”: “~2.2.1”,
“expo-media-library”: “~15.2.3”,
“expo-splash-screen”: “~0.18.2”,
“expo-status-bar”: “~1.4.4”,
“expo-video-thumbnails”: “~7.2.1”,
“path”: “^0.12.7”,
“react”: “18.2.0”,
“react-native”: “0.71.8”,
“react-native-fs”: “^2.20.0”,
“react-native-pager-view”: “6.1.2”,
“react-native-safe-area-context”: “4.5.0”,
“react-native-screens”: “~3.20.0”,
“react-native-tab-view”: “^3.5.2”
“devDependencies”: {
@babel/core”: “^7.20.0”
“private”: true
I am creating a bare expo project that uses ReactNativeFileSystem . when i run the app on my phone using npm run:android it works fine however when i try to run it using expo run , it throws error TypeError: Cannot read property ‘RNFSFileTypeRegular’ of null .SO i decided to create a development build of the app using eas , after creating the build when i run the app using npm start or npx expo start --dev-client or npx expo start , it cant connect to the development build even though its installed .instead it gives this error [redirect middleware]: Unable to determine redirect location for runtime ‘custom’ and platform 'android’ when i click on development build and when i click on expo it throws Cannot read property ‘RNFSFileTypeRegular’ , what am i missing here:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.