The Expo SDK requires Expo error.In Expo client app.

I’m using in app.json:

“sdkVersion”: “35.0.0”,
“platforms”: [
In the package.json:
“main”: “node_modules/expo/AppEntry.js”,
“scripts”: {
“start”: “expo start”,
“android”: “expo start --android”,
“ios”: “expo start --ios”,
“web”: “expo start --web”,
“eject”: “expo eject”
“dependencies”: {
@expo/vector-icons”: “^10.0.6”,
“expo”: “^35.0.0”,
“expo-font”: “~7.0.0”,
“react”: “16.8.3”,
“react-dom”: “16.8.3”,
“react-native”: “”,
“react-native-gesture-handler”: “~1.3.0”,
“react-native-paper”: “^3.1.1”,
“react-native-reanimated”: “~1.2.0”,
“react-native-screens”: “~1.0.0-alpha.23”,
“react-navigation”: “^4.0.10”,
“react-navigation-drawer”: “^2.3.3”,
“react-navigation-header-buttons”: “^3.0.3”,
“react-navigation-material-bottom-tabs”: “^2.1.5”,
“react-navigation-stack”: “^1.10.3”,
“react-navigation-tabs”: “^2.5.6”,
“react-redux”: “^7.1.1”,
“redux”: “^4.0.4”
“devDependencies”: {
“babel-preset-expo”: “^7.1.0”
“private”: true

This is really annoying and is wasting my time too much.I get this error all the time.Even if I switch to a project which did work correctly before I doesn’t know.I don’t know what to do please help!This happens in expo client.

Please provide more info. Can you post the whole error message and explain how/when it appears?

If you create a new blank project with expo init does it happen there too?

Can you post the output of expo diagnostics too?

Thanks for the reply @wodin ure the whole error is:
I created the projects using expo init yes it unfortunantly does that.It used to be okay!I don’t know what’s wrong.It also does:

Finished building JavaScript bundle in 39108ms.

but on the device it gives that error.

Here’s the output of expo diagnostics :

Expo CLI 3.4.1 environment info:
OS: Windows 10
npm: 6.9.0 - E:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-191.8026.42.35.5900203

now also I ran

npm install expo-cli --global

To get the latest version of everything Then I did

expo init my-new-project
cd my-new-project
expo start

And wow!The same error.That’s very wired.also reinstalled the expo_client app no luck again!

Updated expo client to the latest version and no result as well.

I now singed out from the expo in cmd and now it works.But when I sign in I get the same is the problem I need to be singed in for other reasons.But this won’t let me.What shall I do?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.