expo android build => Could not find google-services.json

Hey volks, I have read a lot of reviews and couldn’t find any solution yet. I wanted to build my first android app with expo build:android apk and everything worked well except after install, the app crashes.

It says in the expo logs google-services.json couldn’t be found. I tried many solutions like debug folder, release folder, delete everything, reinstall. Nothing worked yet. Any advice?

  Expo CLI 4.1.6 environment info:
      OS: macOS 11.2.1
      Shell: 5.8 - /bin/zsh
      Node: 15.8.0 - /usr/local/bin/node
      Yarn: 1.22.10 - /usr/local/bin/yarn
      npm: 7.5.4 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      iOS SDK:
        Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
      Android Studio: 4.0 AI-193.6911.18.40.6626763
      Xcode: 12.4/12D4e - /usr/bin/xcodebuild
      expo: ^40.0.1 => 40.0.1
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
      expo-cli: 4.1.6
    Expo Workflow: bare

Hey @viboa, just to clear things up, have you provided a google-services.json file?


Hey @adamjnav ,

sure I did. As I said I tried to changed the paths, different folders etc. it just doesn’t work. I really don’t know what to do. Even if I delete the string from my app.json, it still throws me an error

This is correct behavior, if you see “Parsing json file …” that means it was detected correctly, the log “Could not find google-service.json” is not an error

Somehow I thought the app would crash because of that notification. Somehow when I changed my workflow, deleted android and ios folders, built again, my app doesn’t crash and everything is working fine. When I do change to bare workflow, it crashes.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.