Expo 49: EAS Build Android, adb logcat error at ReactNativeFlipper.initializeFlipper(this, getReactNativeHost().getReactInstanceManager());

So my latest expo 49 bareworkflow eas build android app crashes immediately after opening. I did adb logact and got this follwoing error:

08-29 14:32:10.572 20712 20712 I fb-UnpackingSoSource: dso store is up-to-date: /data/user/0/com.sdl.siamdigitallending/lib-main
08-29 14:32:10.572 20712 20712 V fb-UnpackingSoSource: releasing dso store lock for /data/user/0/com.sdl.siamdigitallending/lib-main
08-29 14:32:10.583 20712 20712 E EmbeddedManifest:      at com.sdl.siamdigitallending.MainApplication.onCreate(MainApplication.java:71)
08-29 14:32:10.583 20712 20712 E AndroidRuntime: Process: com.sdl.siamdigitallending, PID: 20712
08-29 14:32:10.583 20712 20712 E AndroidRuntime:        at com.sdl.siamdigitallending.MainApplication.onCreate(MainApplication.java:71)
08-29 14:32:10.585  1575  3887 W ActivityManager: crash : com.sdl.siamdigitallending,10721
08-29 14:32:10.585  1575  3887 W ActivityTaskManager:   Force finishing activity com.sdl.siamdigitallending/.MainActivity
08-29 14:32:10.585  1575  3887 D ActivityTaskManager: scheduleTopResumedActivityChanged, onTop=false r=ActivityRecord{3201caf u0 com.sdl.siamdigitallending/.MainActivity} t40478 f}}
caller=com.android.server.wm.ActivityTaskSupervisor.updateTopResumedActivityIfNeeded:2508 com.android.server.wm.TaskDisplayArea.positionChildTaskAt:602
com.android.server.wm.TaskDisplayArea.positionChildAt:537 com.android.server.wm.WindowContainer.positionChildAt:970 com.android.server.wm.Task.positionChildAt:3352

The line i have at 71 in my MainApplication.java is this:

ReactNativeFlipper.initializeFlipper(this, getReactNativeHost().getReactInstanceManager());

I have a ReactNativeFlipper.java in my release folder, which basically has nothing as Flipper is not initialized in release builds. It’s like this.

package com.sdl.siamdigitallending;
import android.content.Context;
import com.facebook.react.ReactInstanceManager;
 * Class responsible of loading Flipper inside your React Native application. This is the release
 * flavor of it so it's empty as we don't want to load Flipper.
public class ReactNativeFlipper {
  public static void initializeFlipper(Context context, ReactInstanceManager reactInstanceManager) {
    // Do nothing as we don't want to initialize Flipper on Release.

I tried commenting this line ReactNativeFlipper.initializeFlipper(this, getReactNativeHost().getReactInstanceManager()); from my MainApplication.java file but the apk stucks at installing forever and won’t even install.

My flipper version is


What am i missing here?
Also npx expo run:android works perfectly, it’s npx expo run: android --variant release that fails and also eas built apk

Turns out it’s the problem with my expo updates config. Fixed it, all good now. The logcat was not helpful