Exp publish does not end

I was trying to do a simple workflow to deploy app on exp then commit and push the updated version. But the “exp publish” command does not end that is why it does not go to my next command. So my question is how to make that “exp publish” exits after successful publish? Or there are another ways that still accomplish what i want? You can see the attached file for better understand what is happening.


exp publish is supposed to end.

Here is an example of it ending for me:

ccheever@Charless-MacBook-Pro:~/tmp/blank-project$exp publish && echo done
[exp] Making sure project is set up correctly...
[exp] Your project looks good!
[exp] Publishing...
[exp] Building iOS bundle
[exp] Building Android bundle
[exp] Analyzing assets
[exp] Uploading assets
[exp] No assets changed, skipped.
[exp] Uploading JavaScript bundles
[exp] Published
[exp] Your URL is



I wonder what is different about your situation that is making it not end. Sometimes it may take a moment for the node process to shutdown or to send emails or text messages, etc. noting the end of publishing. Did you try waiting a few seconds after publish finished?

The code for exp is here if you want to dig into and try to figure out what’s going on:

By the way i’m doing this on git-bash on windows, will try again on windows command prompt.i think last time i was using windows command prompt that is why it ends successfully.

Encountered the same issue.
exp publish does not end both on PowerShell and on CommandPrompt.

I have to stop the command-execution explicitly. Stops successfully with this message.

Stopping packager...
Packager stopped.

So it could be something with the packager.

exp version: 47.3.10
npm version: 3.10.10
node version: 6.10.2
OS: Windows 10 Enterprise

Same issue here, any news on that? Tried with cmd and powershell both ways won’t stop the proccess except i’ve hit ctrl+c.

exp version: 50.0.1
npm version: 4.6.1
node version: 8.10.0
OS: Windows 10 Enterprise

1 Like

I’ve also got the same issue as @iamrommel and @vitalragaz with almost the same environment.
Would be awesome if you could fix this issue.

exp version: 50.0.1
npm version: 4.6.1
node version: 8.10.0
OS: Windows 10 Pro

Same issue. Gives me the published link but then hangs. My app appears in my published list, but will not open citing:
“Unexpected error: Application man has not been registered”

Same issue. I tried with cmd, powershell and git bash.

exp version: 55.0.4
npm version: 6.1.0
node version: 10.1.0
OS: Windows 10 Home

It seems that exp team are not interested with this at all. :frowning:

1 Like


Has anyone come across a solution (or workaround) to this problem? It still seems to be an issue with cmd + powershell…

This is making it difficult to integrate the command into a CI / CD pipeline - if anyone has overcome this somehow, advice would be welcome!

Hey @tomosedplus!

Could you provide some more details on your issue? Is the output the same as OP’s? Also, what SDK are you running?

If the output is the same as OP’s, is the provided link for your project working?

Let me know!

Apologies for the very long delay here…

  • The output is same as the OPs.
  • The SDK version is v32.
  • The published project always works fine, just that the publish task doesn’t end.

Performing a Ctrl+C on the task completes the job successfully (once it is clear that all of the publish tasks have been done).

@tomosedplus, what version of the Expo CLI are you using?

@charliecruzan - v2.11.6.

For me it sometimes hangs uploading sourcemaps.

Adding source map references
Uploading source maps for release 1.0.89-r.d2R6pDZMRE

The same started happening to me all of a sudden since yesterday. My CI deployment pipeline on Mac OS (High Sierra) stopped working because of this. I did not make any changes to app.json and did not update any packages. My Expo CLI version is 2.11.7, Expo SDK version is 31, the app is ejected to ExpoKit. Any ideas on how to fix it?

Update: restarting the Mac server seems to have fixed the issue, at least temporarily.