Error with Publish through XDE and CLI - ECONNRESET

I’m trying to test out the publish functionality through the XDE on a simple app. When using publish through XDE or through the command line, I get the same error:

// via XDE Publish button
12:51:38 PM
12:51:39 PM
Building iOS bundle
12:51:41 PM
Building JavaScript bundle: finished in 26716ms.
12:52:07 PM
Building Android bundle
12:52:07 PM
Building JavaScript bundle: finished in 26424ms.
12:52:34 PM
Analyzing assets
12:52:34 PM
Building JavaScript bundle: finished in 9017ms.
12:52:44 PM
Building JavaScript bundle: finished in 7094ms.
12:52:51 PM
Uploading assets
12:52:55 PM
No assets changed, skipped.
12:52:55 PM
Uploading JavaScript bundles
12:53:07 PM
Failed to publish package: read ECONNRESET
$ exp publish
[exp] Making sure project is set up correctly...
[exp] Your project looks good!
[exp] Publishing...
[exp] Building iOS bundle
[exp] Building Android bundle
[exp] Analyzing assets
[exp] Uploading assets
[exp] No assets changed, skipped.
[exp] Uploading JavaScript bundles
[exp] read ECONNRESET
Error: read ECONNRESET
    at exports._errnoException (util.js:1018:11)
    at TLSWrap.onread (net.js:568:26)

I saw this forum topic, Error when trying to run exp publish where the issue seemed to be around the environment variables, but not quite sure what to look into here. I haven’t modified any env variables related to expo and not sure that I have conflicting name like in the other post. Also been googling around and most of these errors seem to be around publishing npm packages. Is there a more verbose option to get more debug output or what is the cause of the read ECONNRESET to look into?

Hi! Sorry you hit this problem! Did you see this multiple times, and have you tried again since seeing this error? What day are the above timestamps from, and what timezone? I’d like to check our logs for the time in question.