Error when launching standalone generated app.

I’m trying to create a build for the Simulator, I followed all the steps detailed here, any error.

After I generated and downloaded the build, I saw my app like this:

Then I opened the simulator and run:
xcrun simctl install booted
xcrun simctl launch booted

The first command worked as expected, but when I tried to launch the app, I saw this error.

I’m not able to launch the app and I could not find any post related to this error.

This is my Expo diagnostic:

Expo CLI 3.4.1 environment info:
      OS: macOS 10.15
      Shell: 5.7.1 - /bin/zsh
      Node: 8.11.1 - ~/.nvm/versions/node/v8.11.1/bin/node
      npm: 6.1.0 - ~/.nvm/versions/node/v8.11.1/bin/npm
      Android Studio: 3.5 AI-191.8026.42.35.5900203
      Xcode: 11.0/11A420a - /usr/bin/xcodebuild
      expo-cli: 3.4.1

Hey @brightplan,

This may be because of Catalina >< One of our team members had an issue with simulator builds and recommends trying this

Let me know if that works for you.


Sorry for the late response, I tried the link you send me but that didn’t work.

Any other idea?

As you correctly said, this started when I upgraded yo CatalinaOS

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.