"Error: EPERM: operation not permitted, rmdir" during EAS file compression

For a few days now I have problems building a new EAS build for my app using the Expo dev client. Before that, everything worked fine - now everytime I run the command I receive this log output/error message:

eas build --profile development --platform android
✔ Using remote Android credentials (Expo server)
✔ Using Keystore from configuration: Build Credentials xyz (default)

Compressing project files and uploading to EAS Build. Learn more: https://expo.fyi/eas-build-archive
    Error: EPERM: operation not permitted, rmdir 
    Code: EPERM
- Compressing project files

If I recall correctly, I saw this error for the first time after I imported some backup files from Google Drive into my app’s project folder. Not sure if this has anything to do with it, but maybe this is where the permissions issue comes from?

Node v16.17.0
Expo CLI v 0.2.11
Expo SDK v46 (Managed Workflow with Dev Client)
eas-cli v 2.1.0

What I tried so far:
-Uninstall Node and install newest version
-Uninstall eas-cli and install newest version
-Update Expo CLI & upgrade SDK
-Delete eas.json and run eas build:configure again
-Give all permissions & rights for all users in the mentioned AppData and the app project folder
-Remove “read only” from all files in the project folder
-Run npm cache clean --force
-Start cmd as administrator to run build command (also tried Powershell)
-Restart VSCode and my laptop

Appreciate any help or tips to find the solution. Thanks!