Entitlement error

SDK Version: 32.0.0
Platforms(Android/iOS/web/all): iOS

Hey, I’m getting the following error – seems to be due to some sort of incompatibility with Apple’s tools. Can anyone provide guidance here? I’ve turned off fonts in my App Id configuration and regenerated all provisioning profiles, certs, and keys.

ITMS-90807: Invalid entitlement - The com.apple.developer.user-fonts is valid only for apps build with SDK 13 or later.


Hi, same exact error when publishing my new binary to app store.
SDK version : 33.0.0
Platform : IOS

To add a little more context: it doesn’t seem like Testflight has any problems with the build for internal testing, it’s just when they approve it for external testing that they send the email and invalidate the build

1 Like

I don’t really know if this is related but do you have fonts activated in your App ID Configuration as mentionned here invalid-code-signing-entitlements ? I do so I may try to remove it

I deactivated fonts before pushing my most recent build – no errors yet but yesterday there was a ~5hr delay between pushing and getting the email. We’ll see…

1 Like

Hey, did you get the same error ?

No issues yet.

My fix: turn off fonts, delete all certs, keys, and profiles, then rebuild and upload

Getting the same error so keen to hear how you get on and if you get approved.

Just submitted my new build after doing the same (unchecking Fonts, regenerated profiles, certs and keys). Will update when I hear from Apple.

I am also having this issue. I’m using PhoneGap, so I can’t uncheck Fonts. I am including custom fonts by including the font file in with my files, and calling it in the CSS file. Does this mean I have to remove my custom fonts?


These forums are for apps written using Expo, so it is probably not the best place to ask about your PhoneGap problem. Even if the error looks the same, the solutions are likely to be different.

OOH, I wondered what Expo meant. Oops! Sorry about that!

1 Like

Have a look at expo.io. Especially if you’re familiar with React. Also docs.expo.io.

This worked for me by the way. I still have custom fonts in the app, but was able to get it approved by following these steps.

1 Like

Same issue here, I am using expo SDK 32.0 :face_with_raised_eyebrow:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.