EAS prebuild fails react-native-reanimated incorrect data check

using managed workflow
eas-cli v46

using command $ eas build --platform ios --profile development

build fails with

[1/4] Resolving packages...
[2/4] Fetching packages...
[stderr] error An unexpected error occurred: " incorrect data check".

I am not using reanimated in my code, and it is not in my package.json
I trashed the node_modules folder and ran yarn install, I don’t know what else to try
Any advice?

reanimated also does not appear anywhere in my yarn.lock file.

we are also experiencing this and are blocked from building ios builds.

1 Like

The only thing that I can think of is that I changed node versions. I did change back, and tried a few versions, also reinstalling eas-cli using those various versions, etc, I also tried various versions of eas-cli, paired with different node versions, but nothing seemed to help.

My feeling is that this is a bug in EAS.

We also had this but worked around it by bumping the react-native-reanimated version. Looks like some others had it and Expo manually cleared a bad cache: EAS Build - Constant Issues - 500 Internal Server Error - #14 by wen-kai

thanks @lisaah !!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.