eas build failure linked to react-native-reanimated

My project works fine in Expo Go on SDK43.

eas build worked fine on SDK42.

However after updating to SDK43 when building with eas an archive failure error pops up right after the line:

› Generating debug MyApp » myapp.app.dSYM

The xcode logs show that wherever 'react-native-reanimated' is being imported xcode is unable to resolve the module.

So something is happening with the debug and react-native-reanimated that is causing my eas builds to fail.

Any tips would be gladly appreciated.

I’ve been spending the past few days just trying to fix this and so far no luck.

are you using a monorepo? is the dependency in your package.json?

@notbrent I’m just using a standard repo.

The dependency is in my package.json.

I’ve tried removing it, downgrading, upgrading and nothing worked so far.

This Eas build only succeeds when "developmentClient" is set to true - #3 by 10000multiplier was the solution.

The error in my app had nothing to do with react-native-reanimated. Sorry