EAS iOS build fails when started from certain PCs


  • Managed workflow (with expo-dev-client)
  • eas-cli/3.2.1 darwin-arm64 node-v16.13.1

The build fails when started from mine or my coworkers PCs but works when started from another coworker PCs. The one that works uses eas-cli/0.52.0 darwin-x64 node-v16.16.0, however, I already tried those exact versions and it fails with the same error. Worth mentioning that we are starting a build from the exact same commit.

FTR this used to work on my PC but stopped all of the sudden a couple of months ago.

The build fails in fastlane with the following message:

Already tried:

  • using the exact same versions as my colleague that manages to create builds
  • expo prebuild --clean

What am I missing?

For what is worth - I managed to fix the issue by opening the project in XCode and checking icloud capabilities under “Signing and capabilities”

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.