EAS fastlane error

Hi All,

I’m trying to build for iOS and running into a strange fastlane error, I see this both when I run in EAS and when I pass --local to do it locally.

[RUN_FASTLANE] › Executing expo-updates Pods/EXUpdates » [CP-User] Generate app.manifest for expo-updates
❌ Metro encountered an error:
While resolving module `react/jsx-runtime`, the Haste package `react` was found. However the module `jsx-runtime` could not be found within the package. Indeed, none of these files exist:

EAS version: eas-cli/0.50.0 darwin-x64 node-v17.8.0

The command I’m running is: eas build --clear-cache -p ios --profile pre-staging --local

And finally, my eas.json profile:

"pre-staging": {
      "env": {
        "REACT_ENV": "pre-staging"

Hope this sparks something from someone, It has me stumped.


have you tried running your project locally in prod mode? expo start --no-dev

it seems like your app is not bundling properly - you may have react/jsx-runtime enabled in your babel config but on an old version of react

Just tried running it, and it seems OK. I will check on my babel config and dependencies, but I also ran expo update. It said I was up to date but running again could potentially catch any stale dependencies, so I let it run but didn’t seem to help.

can you share your babel config? babel.config.js