Eas build yarn.lock not found


I’m still having trouble with my build for while now.

For an obscur reason, EAS use npm to install dependencies, which fail cause one of our dependencies is not on npm.

My repo does NOT contains a package-lock currently, but it may already had one in the past.

I noticed that we are using Yarn 1.22.17, so I added a eas-build-pre-install script as seen on the eas doc: Integrating with third-party tooling - Expo Documentation.

This lead to a new hint on my problem. On the Pre-install hook step where it run eas-build-pre-install script I notice this error

sed: yarn.lock: No such file or directory

Of course, I do have a yarn.lock on the root of my repo, what could make EAS think I do not ? Is there some form of caching I could delete ? I tried to add cache: { disabled: true} on my eas.json, but still got this error

Any idea why EAS does not see my yarn.lock ?

it sounds like yarn.lock may not be committed to git / ignored by your gitignore. use eas build:inspect to generate an archive and then inspect that archive to see what files are included and not

Hi, How are you using yarn instead of npm in eas build. Can you pls share package.json and eas.json files.

You just need to make sure that yarn.lock committed to git and do not list it in .gitignore (or .easignore). Also you should not have package-lock.json.

Thank you,
It worked