EAS Build not showing release channel [solved]

  • Two projects, bare and managed workflow
  • EAS version: eas-cli/0.45.1 darwin-x64 node-v16.6.1

Quite a simple question, though I can’t seem to find the answer anywhere. The image shows builds (using EAS) for 2 separate projects. One is bare workflow and the other is managed workflow.

I can set the release channel for the bare workflow app (and it defaults to ‘default’ when not set) but I cannot do so for the managed workflow app. It doesn’t seem to even default to anything. How can I set a release channel for the managed workflow app when building with eas build?

What I’ve tried:

  • adding releaseChannel as a key in eas.json
  • Reading a lot of documentation + trial/error on eas.json config, but with no luck

Thank you in advance for your help!

Solution: this specific line in the (Build schema for eas.json)[Build schema for eas.json - Expo Documentation] docs says that release channels only work with expo-updates installed!

Consider adding this to the release channels / eas build documentation. Thanks! :slight_smile:

Thank you for sharing that. We came into this issue yesterday and agree that the release channels definitely need more clarity, and having the internal package ‘expo-updates’ installed is a critical thing to note in the docs.

Also it’d be great to have a way to better understand when ‘expo’ is the appropriate tool and when we should be using ‘eas’. It feels like ‘eas’ is intended to be the way going forward but there is a lot of mix and match of these commands.