Eas build - crash after app open


Recently I have upgraded my app to expo v42. I run expo run:ios to generate the ios folder because I wanted to add custom code. Everything is working ok, I can run the app from expo run:ios, it works on the simulator. The problem is on eas build. After I run eas build it builds successfully, but when I try to install the app on my device (which I created an ad-hoc profile for the device) it is all black screen for a couple of seconds and then it crashes. I was able to run the app on the simulator from xCode and I tried to archive the project from xCode which worked. Any reason for this?

Also do I need to run metro server when running the eas build on simulator or on device?


  "build": {
    "release": {},
    "preview": {
      "releaseChannel": "sim",
      "ios": {
        "simulator": true
    "development": {
      "releaseChannel": "internal",
      "distribution": "internal",
      "android": {},
      "ios": {}

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.