EAS build do not work in TestFlight

Please provide the following:

  1. SDK Version: 45
  2. Platforms(Android/iOS/web/all): iOS
  3. EAS build

Hello Guys,
I am having problems to build a version to deploy in app store(TestFlight).
when I build a version to test locally in my device the app works correctly.

{
   "build": {
    "development": {
      "developmentClient": true,
      "distribution": "internal"
    },
}

Then When I change the eas.json to create a build to use in TestFlight, the app crash when start to load the splash screen.

{
  "build": {
    "preview": {
      "distribution": "store"
    }
  }
}

Also when I use EXPO CLI with Expo build:ios command the build work perfectly in TestFlight.
Please if anyone could helo me with this Ill appreciate a lot. having this issue for weeks.

hi there! i recommend referring to this page: Troubleshooting build errors and crashes - Expo Documentation

if you can’t figure it out after following those instructions, the bottom of the page has instructions for how to ask a good question that people can help you with

Thank you for your reply @brents. I was looking into this page but not manage to get a solution.
the app work correctly with expo build and eas build --profile development
but crash in Testflight when I make a build for production.

all the building process are passing without errors:

Any reason you modified the preview build profile to change the distribution instead of just using the production build profile?

I tried to run with production but the build crash so then I use the preview profile and set subscription to store to see if going to work but still the same issue.

Please be very clear about what you mean by “but the build crashed”. Rather solve that problem.

When I create a build for production(eas build --platform ios ) and I upload the version to TestFlight the app breaks or crash soon the splash screen start to load and keeps showing a white screen.

If I run the app in development mode using
eas build --profile development --platform ios
then install the version in my phone
and run it with : expo start --dev-client
The application work correctly

Please see the Production errors section of the debugging documentation. Especially the “Hint”.

If that doesn’t help, try https://expo.fyi/manual-debugging

After running
npx expo start —no-dev —minify

Expo Go shows:


Ok, that’s good, because now you can experiment locally to see what is causing the problem.

Try with only --no-dev and with only --minify to see if it still causes the error, but maybe gives you better error messages.

Also try the “manual debugging” document.

I remove the library react-native-purchase and Run expo start —no-dev —minify
now I do not having any console errors.
when I run this version in development mode using eas build --profile development --platform ios
the app run ok in my device.

When I create a version for TestFlight using eas build --platform ios
the app crash(just show a white screen) in the moment that its opened.

I am not sure if it is something related to eas configuration.
before I make the build using expo-cli.

There’s not enough information for me to know what the problem is.

Please try the manual debugging document I linked to in a previous message.

Morning,
After looking what is causing the app crash when start to load ( only happen with production build using EAS buil) was because the “entryPoint” was declared in my app.json
This was set when I created the project with old Expo version 37 or 38 if I believe.
Now the new Expo45 or newer have set the entryPoint in the package.json. Same thing for the appName and versión fields.
With this 3 field declared in my package.json and not in the app.json the app is working correctly for both development and production builds using the new EAS build.

Thanks the support
Kind regards

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.