Custom CLI build – Unable to fetch manifest from:

I’m trying to build a custom Expo CLI. I’m stuck on the step:
Would you like to register a new device to use the Expo client with?

If I choose “no”, the process fails with message:
Unable to fetch manifest from:

If I choose “yes”, the email never comes.

 Expo CLI 3.21.5 environment info:
      OS: macOS 10.15.3
      Shell: 5.7.1 - /bin/zsh
      Node: 13.11.0 - /usr/local/bin/node
      Yarn: 1.22.4 - /usr/local/bin/yarn
      npm: 6.13.7 - /usr/local/bin/npm
      Android Studio: 3.6 AI-192.7142.36.36.6308749
      Xcode: 11.4/11E146 - /usr/bin/xcodebuild
      expo: ~36.0.0 => 36.0.2 
      react: ~16.9.0 => 16.9.0 
      react-dom: ~16.9.0 => 16.9.0 
      react-native: => 0.61.4 
      react-native-web: ~0.11.7 => 0.11.7 
      expo-cli: 3.21.5

What should I do to get passed this step?


I’m having the same issue. Did you figure it out?

I tried this a day later and it worked after hitting “n”. By the way, prior to encountering this issue I also had to find my device’s udid (via get . udid . io) and register it manually with my “team” on Apple’s developer site.

Now the build for the custom iOS Expo Client has completed, and I am unable to install it. It says,

(“null)” is Already Installed
“(null)” has the same Bundle ID as “(null)” and can’t be installed. To continue, delete “(null)” from your device and try again.

I guess I will make a separate post about this and maybe a github issue. I found this thread on apple discussions, but I don’t see any unnamed app on my app list. This post suggests setting legacy build mode, and I don’t know how to do that in expo.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.