Couldn't start project on Android: Error running adb:

I’m not even 100% sure how this error started but I am unable to run my project on an emulator at the moment.

Android Studio: 3.4.1
Emulator: Pie API 28
Expo SDK: 32.0.6
Expo CLI: 2.19.4

General workflow is to open the emulator and make sure it is up and running.

Go to the command line and hit expo start wait for the initialisation and the hit a

Upon doing so i now get the error “Couldn’t start project on Android: Error running adb:”

After lots of searching the internet I cannot find any other reference to this specific error. There are plenty of examples of when further information is posted after the “Error running adb:” bit including no device, adb not installed etc. but nothing that is an empty error message.

I’ve tried uninstalling Android Studio.
I’ve removed all Android Studio registry entries.
I’ve tried installing the platform tools independently from Android Studio.

I’m at a loss on where to go with this as there seems to be little information out there on where to go next.

Any ideas or help very welcome here.



1 Like

Have the same error after reseting windows 10 and re-installing adb via android studio, have been looking on google but did not found error with empty message too.

λ adb --version
Android Debug Bridge version 1.0.41
Version 29.0.0-5611747

λ expo --version

I have the same version of adb as well.

I wonder if this is related to a recent windows update?

I would be happy to investigate if anyone can point me in the direction of what to check.

Hey guys, there’s a github issue open for this, want to try and keep the conversation in this one place. Did this only crop up after the Windows update?

Of course, makes sense to keep it in one place. I somehow didn’t manage to find that issue during my searching.


1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.