Could not load embedded manifest (android)

ExpoKit app is working perfectly until I try to generate a signed APK. When I install this APK on my phone, I get this error, saying “could not load embedded manifest, are you sure you published, etc…”

This is very similar to here:

But in that case, the bundle path and manifest path were not getting written in app.json after publish. In my case, these keys are successfully written and the associated files are generated at the correct folder after publish. Everything appears as it should, but I still receive this error.

I’ve remade the project several times from scratch, as well as changing the slug and pretty much every relevant parameter I can think to refresh. No luck.

What else can I try to debug this?


Still no response so I’ll try to provide more context. In app.json, I’ve turned “updates” / “enabled” to false. Perhaps that has something to do with the issue? I turned it off because the cached app never stored my assets properly, and the app would break any time it loaded from the expo servers.

Second point is that I installed the app using “adb install” which I think is the method suggested in your docs. Not sure if that would be any different to using Android console. But just another note.

I am experiencing this issue as well with SDK 30. It was working fine before we upgraded from SDK 27.

I never had any defaults set, but I enabled updates and came to the same issue. Curiously, I tracked down what seemed to be the root cause (a function in that tries to only use cached assets), or so I thought since the function still seemed to be getting called even with updates enabled.

  // this is used only if updates.enabled == false
  public void fetchEmbeddedManifest(final String manifestUrl, final ManifestListener listener) {
    String httpManifestUrl = httpManifestUrlBuilder(manifestUrl).build().toString();

    Request.Builder requestBuilder = ExponentUrls.addExponentHeadersToManifestUrl(httpManifestUrl, manifestUrl.equals(Constants.INITIAL_URL));
    requestBuilder.header("Exponent-Accept-Signature", "true");
    requestBuilder.header("Expo-JSON-Error", "true");
    String finalUri =;

    String embeddedResponse = mExponentNetwork.getClient().getHardCodedResponse(finalUri);

    try {
      JSONObject embeddedManifest = new JSONObject(embeddedResponse);
      embeddedManifest.put(ExponentManifest.MANIFEST_LOADED_FROM_CACHE_KEY, true);
      fetchManifestStep3(manifestUrl, embeddedManifest, true, listener);
    } catch (Exception e) {
      listener.onError(new Exception("Could not load embedded manifest. Are you sure this experience has been published?", e));

And here is the logcat output that drove me there:

10-25 13:33:48.042 9580-9580/? E/c: Could not load app: java.lang.Exception: Could not load embedded manifest. Are you sure this experience has been published?
10-25 13:33:48.045 9580-9580/? W/System.err: java.lang.NullPointerException: Attempt to invoke virtual method 'int java.lang.String.length()' on a null object reference
10-25 13:33:48.045 9580-9636/? D/libEGL: loaded /vendor/lib/egl/
10-25 13:33:48.045 9580-9580/? W/System.err:     at org.json.JSONTokener.nextCleanInternal(
        at org.json.JSONTokener.nextValue(
        at org.json.JSONObject.<init>(
        at org.json.JSONObject.<init>(
        at host.exp.exponent.g.c(
        at host.exp.exponent.c.a(
        at host.exp.exponent.experience.b.onCreate(
        at android.os.Handler.dispatchMessage(
        at android.os.Looper.loop(
        at java.lang.reflect.Method.invoke(Native Method)

Another bit of weirdness that @pcowgill and I noticed in our project is that Expoview seems to be still pegged from v27, but maybe that was due to the last time we had to start a new project and detach.

1 Like

Faced exactly the same problem. It worked fine on expo 27 but stopped after upgrade to expo 30.

Hey guys! Could you please ensure that the URL that is returned in in publishedUrl is the same as the one at around lines 30–31?


  public String publishedUrl() {
    return "exp://";

        embeddedResponses.add(new Constants.EmbeddedResponse("", "assets://shell-app-manifest.json", "application/json"));
        embeddedResponses.add(new Constants.EmbeddedResponse("", "assets://shell-app.bundle", "application/javascript"));

This is the code that is generated at the moment. Could you please try copying URL of the embedded response to the publishedUrl? In my case I would copy and put into publishedUrl.

Let me know if this helps you solve the issue!

1 Like

works like a charm!

hi all, what expo command line tool are you guys using? we’ve recently migrated from exp to expo, and now all our updates and fixes go to the expo cli. We’ve made some updates to how the manifestUrl gets processed, but that is only available with the more recent expo. Could you try updating the cli (if you havent already) and check if you are still seeing this problem?

Fixed in the latest release of expo-cli (2.2.6). :slightly_smiling_face: npm i -g expo-cli will fix future ejects. :tada:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.