Convert to Managed Workflow

  1. SDK Version: “expo”: “~49.0.8”
  2. Platforms(Android/iOS/web/all): ios

I am getting the following error when using eas update
You’re currently using the bare workflow, where runtime version policies are not supported. You must set your runtime version manually. For example, define your runtime version as “1.0.0”, not {“policy”: “appVersion”} in your app config.

I’m not sure how I got to a bare workflow but I would like to switch to a managed workflow if possible. What would be the steps to do this? We’re already approved in the ios App Store if that makes a difference.

Thank you!

hi there! you can delete the ios / android directory in your project. those can be generated automatically when you run npx expo run:[android|ios] or npx expo prebuild. this is called continuous native generation: Continuous Native Generation (CNG) - Expo Documentation

Thanks for the quick response. I followed these steps and it’s still showing as “bare”. Maybe this output helps?

eric@eric ghostoffer % npx expo-env-info

expo-env-info 1.0.5 environment info:
OS: macOS 14.0
Shell: 5.9 - /bin/zsh
Node: 18.3.0 - /opt/homebrew/bin/node
Yarn: 1.22.18 - /opt/homebrew/bin/yarn
npm: 9.1.2 - /opt/homebrew/bin/npm
CocoaPods: 1.11.3 - /opt/homebrew/bin/pod
Platforms: DriverKit 23.0, iOS 17.0, macOS 14.0, tvOS 17.0, watchOS 10.0
Xcode: 15.0/15A240d - /usr/bin/xcodebuild
expo: ~49.0.8 => 49.0.9
react: 18.2.0 => 18.2.0
react-native: 0.72.5 => 0.72.5
eas-cli: 5.2.0
expo-cli: 6.3.10
Expo Workflow: bare

that check will look for an ios or android directory. if you delete those then it’ll appear “managed” again. we need to update the terminology here a bit

1 Like

In case it’s still unclear:

  • When you have ios and android directories in your app, npx expo-env-info etc. will say it’s Bare.
  • If you run npx expo run:android or npx expo run:ios, it automatically runs npx expo prebuild, which generates the ios and android directories, resulting in a “Bare” app.

So, as Brent said, delete those directories to switch back to the Managed workflow.

1 Like

Ah ok, I understand. now. The only reason I was running pre-build was because my version and build numbers weren’t updating and another issue suggested I run npx expo prebuild to update the versioin and build number. That must have flipped it to bare. Thank you both. I will research a better solution to the version number issue.

how are you setting the version and build numbers in your app? App version management - Expo Documentation

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.