Cannot set runtimeVersion for EAS Update

Hello here,

We are currently struggling on migrating from expo publish to eas updates.
We followed these guidelines: Migrating from Classic Updates to EAS Update - Expo Documentation

When it comes about setting the runtimeVersion, we can’t find any working value:

  • If we set the policy to sdkVersion, we get a New update available, downloading... message but nothing else, even after waiting ~10 min.
  • If we set the policy to nativeVersion or appVersion, we get a Incompatible SDK version or no SDK version specified. error message while starting the app.
  • If we directly set a version (like “1.1”, which would be the best case for our update strategy), we get the same error message than above.
  • If we don’t set anything, the CLI returns this: Error: Unable to determine runtime version for android

Additional info:

  • Managed workflow
  • expo: 46.0.10
  • expo-updates: 0.14.5
  • eas-cli: 2.1.0

Thanks for any help! :pray:

Hey @sylvainkds,

Can you please try the command mentioned here: eas update - Error: Unable to determine runtime version for android · Issue #1266 · expo/eas-cli · GitHub? As described in the comment, the error message does not seem to be the most helpful one.

Let me know how it goes.

Thanks for your reply @amanhimself.

I’ve already tried this command, it keeps asking to change our app.config.ts with values that are already set.

Here is the current config:

import { ExpoConfig } from '@expo/config';

const projectId = 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx';

const config: ExpoConfig = {
  extra: {
    apiBaseUrl: process.env.API_BASE_URL,
    apiVersion: process.env.API_VERSION ?? 1,
    eas: {
  runtimeVersion: {
    policy: 'sdkVersion',
  updates: {
    url: `${projectId}`,
    fallbackToCacheTimeout: 15000,

export default config;