Can't run a project on the simulator after cloning it


I just cloned my existing project repo (just expo boiler plate) and 'npm install’
Once the project is opened, it prints below and nothing pops up in the simulator.

Couldn't start project on Android: ADB server didn't ACK
* failed to start daemon *
error: protocol fault (couldn't read status): Connection reset by peer
error: protocol fault (couldn't read status): Connection reset by peer

And I tried it with my phone too and the screen is stuck on loading.

I tried to kill and start the adb server. But I can’t still fix the problem!

jaemin@jaemin-desktop:~/Desktop/Stylee/workspace/Stylee-Mobile$ adb kill-server
* server not running *
jaemin@jaemin-desktop:~/Desktop/Stylee/workspace/Stylee-Mobile$ adb start-serveradb server is out of date.  killing...
cannot bind 'tcp:5037': Address already in use
ADB server didn't ACK
* failed to start daemon *

Please help

Thanks for your support!! :slight_smile:

Are you currently running an Android emulator or anything else in Android Studio? I’d recommend checking the output of ps aux for any running adb processes and kill those. Or restart your computer.


I restarted my computer and it prints…

jest-haste-map: Watchman crawl failed. Retrying once with node crawler.
  Usually this happens when watchman isn't running. Create an empty `.watchmanconfig` file in your project's root folder or initialize a git or hg repository in your project.
  Error: Watchman error: A non-recoverable condition has triggered.  Watchman needs your help!
The triggering condition was at timestamp=1502758606: inotify-add-watch(/home/jaemin/Desktop/Stylee/workspace/Stylee-Mobile/node_modules/lottie-react-native/lib/android/build/intermediates/res/merged/debug/values-si-rLK) -> The user limit on the total number of inotify watches was reached; increase the fs.inotify.max_user_watches sysctl
All requests will continue to fail with this message until you resolve
the underlying problem.  You will find more information on fixing this at Make sure watchman is running for this project. See

Somehow I’m getting watchman error quite a lot. I’m using ubuntu. :frowning:

Just reset my watchman

echo 256 | sudo tee -a /proc/sys/fs/inotify/max_user_instances
echo 32768 | sudo tee -a /proc/sys/fs/inotify/max_queued_events
echo 65536 | sudo tee -a /proc/sys/fs/inotify/max_user_watches
watchman shutdown-server
watchman watch-del-all

and restarted the project (using ‘Restart’ Button at the Expo XDE)

And the simulator shows the white screen with Made with Expo at the buttom.
So I opened ‘Remote JS Debugger’. I could open the JS debugger browser, but the simulator is stuck on ‘Connecting to remote debugger’ with the green bar at the top.

watchman works fine now. when I save the file, it loads the file. (Once connecting to remote debugger, I can’t refresh and watchman doesn’t work either)

Thank you

Just re-started the simulator and that fix the issue. Not everything works fine.

Thank you so much!

1 Like