Cant resolve processColor anymore

Hello guys,

I just recently upgraded from bare 36 to bare 37. It was successful. The only problem I am getting is:
I cant run the web version anymore. The error I am getting is:

Module not found: Can't resolve '../Utilities/Platform' in '/x/frontend/appUpdate/node_modules/react-native/Libraries/StyleSheet'

The application does work on android and ios as expected.

Ideas I had:

  • I reverted the changes (because I commited only the changes done by upgrade) which apparently does not work i get the same error
  • I set up a new application and changed from SDK 36 bare to SDK 37 managed, I get the same error, IOS and Android do work
  • Tried to update every dependency to the latest update
  • tried deleting the node_modules folder and reinstall
  • tried running expo start -c

here you got my package.json

  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  "dependencies": {
    "expo": "~37.0.3",
    "react": "~16.9.0",
    "react-dom": "~16.9.0",
    "react-native": "",
    "react-native-screens": "~2.2.0",
    "react-native-web": "~0.11.7",
    "@react-native-community/masked-view": "^0.1.6",
    "@react-navigation/native": "^5.1.3",
    "@react-navigation/stack": "^5.1.3",
    "firebase": "^7.13.1",
    "react-native-elements": "^1.2.7",
    "react-native-gesture-handler": "^1.6.1",
    "react-native-progress": "^4.1.0",
    "react-native-reanimated": "^1.7.1",
    "react-native-safe-area-context": "^0.7.3",
    "react-native-unimodules": "~0.7.0",
    "react-native-vector-icons": "^6.6.0",
    "react-redux": "^7.2.0",
    "redux": "4.0.5",
    "redux-thunk": "2.3.0"
  "devDependencies": {
    "@babel/core": "^7.8.6",
    "@types/react": "~16.9.23",
    "@types/react-native": "~0.61.17",
    "babel-preset-expo": "~8.1.0",
    "typescript": "~3.8.3",
    "@testing-library/jest-native": "^3.1.0",
    "@testing-library/react-native": "5.0.3",
    "@types/jest": "^25.1.4",
    "@types/react-redux": "^7.1.7",
    "@types/redux": "3.6.0",
    "@types/redux-mock-store": "^1.0.2",
    "@types/testing-library__react": "^10.0.0",
    "babel-plugin-module-resolver": "^4.0.0",
    "husky": "^4.2.3",
    "jest": "25.2.3",
    "jest-expo": "~36.0.1",
    "react-native-testing-library": "^1.13.0",
    "redux-mock-store": "^1.5.4",
    "ts-jest": "^25.2.1",
    "tslint": "^6.1.0"
  "husky": {
    "hooks": {
      "pre-commit": "npm run precommit"
  "private": true

Is there any help on this I am facing the same?

I can tell you one thing - I resolved the error by changing the import of Platform! But that does not matter because the original code should work! This file has nothing to do why it does not work still it gets point out that the error lives there - which is just WRONG!

I started a new Project and got it running on web and the 2 Files look identical so it cant be anything to do with processColor.js


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.