Can't launch an ipad or any other iOS simulator

The iphone 12 pro max has been the default thing that launches when I run expo start --ios but right now I’m trying to get screenshots on different device screen sizes but when I open the simulator>windows>only the iphone is listed.

The Hardware tab is missing from the navbar simulator navbar.

And when I launch another simulator from xcode to then hopefully get the app launch via a tunnel it is not possible because I can’t install expo app on them.

I have tried to do it via command line by pasting the device id and it couldn’t find those devices either.

How can I get expo to open different iOS simulators?

everything is updated to the latest version.
Expo v39
macbook Big Sur
iOS 14.2
Vscode 1.51.1

Hey @a_creative_username, you can open up a different simulator and then run the command expo client:install:ios and it will install the Expo client on that simulator.


I’m embarrassed to say this but they had changed the location to it and I couldn’t find it in any google search or documentations for 4hrs.

File > open simulator > pick your ios version > pick your device

I’m mad at myself and apple for that. Beyond annoying

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.