Can't build default app on ios

Hi everyone. I’m having a strange and annoying problem. After spending some time on a different project, I switched back to my app, and it won’t build anymore on my system. As I often do when the app breaks, I created a new project from scratch to see if I have the right version of everything. I can’t even get the default project to build. It’s a bare workflow and I’m running yarn ios.

I’m getting a lot of warnings, but this seems to be the only failure:

The following build commands failed:
	CompileSwiftSources normal x86_64 (in target 'ExpoModulesCore' from project 'Pods')
	PhaseScriptExecution [CP-User]\ Generate\ Specs /Users/user/Library/Developer/Xcode/DerivedData/testapp-buzdrledulpbpbbkpmfvprgzlxmi/Build/Intermediates.noindex/ (in target 'FBReactNativeSpec' from project 'Pods')
(2 failures)

I can run the bare app on Android and I can also run a managed app on ios.
Anyone have any ideas about this? I recently upgraded my system to macOS 12.1 and have Xcode 13.2

Earlier in the long error message is this:

Command CompileSwiftSources failed with a nonzero exit code
/Users/chrisking/projects/vanwalks-test-app/test-app/ios/Pods/Pods.xcodeproj: warning: The iOS Simulator deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions is 9.0 to 15.2.99. (in target 'boost-for-react-native' from project 'Pods')

But when I fix that, I still get the other errors.

this is an upstream react-native issue: React Native's initial project doesn't run on IOS. · Issue #31249 · facebook/react-native · GitHub

the thread there describes some ways to work around.

I’ll try those fixes and see if anything helps. Weirdly, I can run the default app with npm run ios but it still fails on yarn ios. I still can’t get my app to run, but I’ll keep trying.

did you change anything recently with your node setup? try uninstalling node entirely and reinstalling it

I updated node and yarn and now I can run yarn ios. Thanks so much for the suggestion. What a strange set of errors.

It appears I spoke too soon. I was able to run it, but after a while yarn ios stopped working on both apps. Not sure what changed, but I can run npm run ios so I’m ok for the moment.

Same here. Downgraded yarn to 1.22.11 and it worked.

npm install --global yarn@1.22.11