Can't build apk with exp build:android -c

Can anyone help me :frowning: This error happen anytime i try to build apk. I think i have a problem with my key store. But i don’t know how to fix it :frowning:

My build ID:0688e567-263b-4c14-a29d-6d18c6af6a80


Could you check if you are using the newest version of expo-cli? Notice that command line tool is now named expo, exp is deprecated.

I will try and tell you result ^^

@quyenphamkhac Same error here after running this command .

expo build:android -c
Apk is generated but from new account it is not uploading on play store.
Error :-

Upload failed
You uploaded an APK that is signed with a different certificate to your previous APKs. You must use the same certificate. Your existing APKs are signed with the certificate(s) with fingerprint(s):
and the certificate(s) used to sign the APK you uploaded have fingerprint(s):

Issue :- Android Upload and build .ipa failed, Cause of SHA certificate

@biplov14 it’s completely different issue. Please do not confuse other people.

it’s not working although i’m trying expo build:android -c,

this is build ID: 28fa2dc4-c1fc-4d1d-985c-2d59b9d8b328

okkk sorry @jakubste.
but me need expo help immediate.

It’s probably related to a keystore in some way. Are you sure you’re pasting passwords correctly and the file is correct?

If you try building with credentials generated by expo it’s working alright?

the same error with credentials generated by expo :frowning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.