Certificate APK Android

I have an App on Google Play. This app has been available in the store since 2006, it has more than 100k installation.
Now I did an update using the expo and gave the following error.

“You have submitted an APK signed with a different certificate than the previous APKs. Use the same certificate. Your APKs are already signed with certificates with the following fingerprints:”

However I used the command expo build: android -c to send the old certificate, how should I proceed.

grateful if anyone can help me



Are you using latest expo-cli?

Can you try providing this keystore again with EXPO_LEGACY_API=true expo build:android -c? Check before and after output of expo fetch:android:hashes after change hash should match value from play console.

If this won’t help try using expo credentials:manager



I tried EXPO_LEGACY_API and it’s not working either, the hashes are differents.

I ran expo credentials:manager and i uploaded my own keystore, and I can see the same hash now

Running a build now

Thanks for all your help

Hey elton & juan, would you mind confirming whether the problem persists after upgrading expo-cli to the latest version? We’d like to fix the issue for others if possible.


I did an update last night, in one of my test.

I’m using the lastest version

The only way to fix this is doing:

expo credentials:manager

I have 3 apps created with Expo 25 versions in 1, and 15 versións in the others, unfortunatelly this is the only way to fix it now.

Thanks for your help and support


1 Like

Thank you Wkozyra.

my problem was solved using your help. Thank you very much.
I used the command.

EXPO_LEGACY_API=true expo build:android -c

We ran into this issue with a new app (re-using an old key). We also had to do expo credentials:manager and upload the keystore there. otherwise expo kept creating its own keystore, even when we provided one during build.

Thanks for writing in with that. Would you please let us know if running: EXPO_LEGACY_API=true expo build:android -c works?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.